Jan
07

Rb Framework 1.1.0 Released, Do Update all dependent products

For Developers - It reduces maintenance efforts and with few efforts you can build basic components. In short, put energy of plugin and get component as output.

For Customers - Product development over a framework will makes your website faster by removing duplicate code, which also a key factor of SEO.

The best part is that it handles In recent, an update on the implementation of the Framework for removing depreciated code with some Improvement has been done.
Due to this all dependent products get affected.

Dependent products on Rb Framework :-

  • PayPlans App Store - Payplans is Not dependent on Rb Framework, but its App store depends on this. This will auto update (if new version is available.) as you click on Upgrade button at App Store.

  • PayInvoice - Product and App Store Both depends on this.

  • JxiForms - Product and App Store Both depends on this.

  • PayCart - Newly released Shopping Cart is also build on Rb Framework :)

App Store - This is common App Store for all dependent products. (PayPlans, Pay Invoice, Jxi Forms). So update at one place and it will work for all.

Rb Framework 1.1.0 updated with plenty of fixes. Most notably, if you are using multiple rb framework dependent products then you have to upgrade all of them for proper working. If you have done lots of customization in any of these products then its advisable to update once you take proper backup of changes.

  • If you are using only one of these products then Rb Framework and App Store will automatically get updated as you click on Upgrade button in App Store Pop Up.

  • In case if you are using multiple Rb Framework dependent products then you need to manually install Rb Framework and then upgrade all dependent products wrt latest released framework version.

Download Rb Framework 1.1.0

Note :- If you can not update any of the dependent extension either due to any customization or due to any other reason then do not update RB Framework as well, else your product and App Store section not worked properly.

Disclaimer -

  1. If you are using previous version of Rb Framework ie Rb 1.0.*and don’t want to update existing products for new features then nothing to worry. As Rb 1.0.* series is completely secure, safe and stable.
  2. If you want updated and enhanced features and fixes then you should upgrade your Rb framework and dependent products.

While if you have any doubts or feedback, then you can comment below or share them at [email protected]

It is an extremely important task to update all extension with update of framework.

We understand that updating all the dependent kits increase little bit of complexities, but it is of extreme importance to get updated with latest released version.

Author
/ / Category - PayPlans / 4733 visits